Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 16, 2025 - 13:00 EDT
Scheduled
The new Annual Meeting website (www.asco.org/annual-meeting) will be launching on the afternoon of April 16, at or around 1:00 PM ET. The maintenance window for this work will be from 1:00 PM - 6:00 PM ET.
Part of this work will involve switching content management platforms and URLs. Some users may experience temporary or intermittent errors such as Page Not Found (404) or blank pages during the maintenance window, but we expect this impact to be minimal.
Meeting registration through ASCO's registration vendor will not be affected at this time, but the AM registration page may be affected. The ASCO Program Guide is not affected by this work.
Our team will be available to monitor the website during the maintenance period. This message will be updated automatically once the maintenance window has closed. Any other impact to users will be communicated as needed.
Thank you for your patience.
Posted Apr 14, 2025 - 10:14 EDT
This scheduled maintenance affected: Websites (ASCO.org, Meeting Sites).